my battery and airbag lights stays on after an engine wash

ECUs, intakes, turbos, fluids, transmissions, exhausts etc.
askadz
UB Junior Member
Posts: 3
Joined: 27 Jul 2014, 7:12 pm

Post by askadz » 11 Nov 2014, 1:47 am

i have mazda 3 2010 model, my battery and airbag lights stays on after washing the cars engine what's the problem? i wash my car engine with wd40, what should be the problem? the car is running fine. anyone can help me and give me an idea? thanks

User avatar
Alpha
Adminstrator
Posts: 6251
Joined: 17 Apr 2006, 6:36 pm
Vehicle: RNN14 + JZZ31 + CT9A
Location: Dubai
Contact:

Post by Alpha » 11 Nov 2014, 7:10 am

How long since it's been like that?

askadz
UB Junior Member
Posts: 3
Joined: 27 Jul 2014, 7:12 pm

Post by askadz » 11 Nov 2014, 7:46 pm

now its already 3 days and according to what other says i need to replace an alternator? so my question is is that it really? what do you all think guys' thanks sam

User avatar
Alpha
Adminstrator
Posts: 6251
Joined: 17 Apr 2006, 6:36 pm
Vehicle: RNN14 + JZZ31 + CT9A
Location: Dubai
Contact:

Post by Alpha » 11 Nov 2014, 11:48 pm

Your car wouldn't survive for three days with a faulty alternator but it could be that too. You should normally wait for the engine to dry up hoping for the lights to go away but since your airbag light has come up too, try resetting ECU. Disconnect negative terminal of your battery for a few minutes, connect back and start up.

User avatar
Stok
UB Addicted Member
Posts: 187
Joined: 03 Feb 2012, 3:45 pm
Vehicle: Eclipse 1995
Location: Dubai

Post by Stok » 12 Nov 2014, 9:58 am

askadz wrote: anyone can help me and give me an idea? thanks
i cane give you an idea - yours hands are really curly and you made big fail trying to save 30AED on engine wash.
i think qualified plastic surgeon should be able to fix that. Bud you going to remain greedy.



Post Reply